Ktouth Brand. on Web

け〜くんこと K.Ktouth のだらだらした日常と突発的に作るプログラムや読み物とかの雑多サイト



[2008年03月12日]

FeedをRSS2.0に変更

タグ: 更新履歴Ruby
2012年02月23日 13:35更新 筆者:K.Ktouth

RSSフィードを標準のプラグインではなく自前で実装するのなら、簡単に生成できるようにとrss/makerライブラリを使用したんです。
とりあえずRSSのバージョンは2.0で行くことに。

……ところが。
設定したはずのAuthor要素がうまくフィードリーダー(headlinereader)に読み込まれていない模様。
調べてみると、Author要素はメールアドレス必須っぽい……それは良いとしても、正しいフォーマットで入力してもフィードリーダーで認識してもらえない。どうも<dc:creator>要素しか筆者名として認識しない仕様みたいです。
で、オンラインマニュアルに記述されているように

item.dc_creator.new_creator.content = 'オレオレ'

と記述したものの……エラーはないけど出力されないという状態にげー
RSSバージョンを1.0に指定するとエラーもなくただしく出力されるんですが。

……で、3時間弱経過。ようやく判明。

RSS2.0で出力するとxmlns:dc=〜という名前空間宣言すらなかったので気になってはいたんですが、要は「Ruby標準添付のライブラリのバージョンでは非対応」って事でした orz
cygwin版1.8.6では0.1.6表記のrssライブラリも、ネット上での配布の最新バージョンは0.2.3!!
オンラインマニュアルは当然ながら最新版に追随してますから、そりゃ仕様が食い違っても仕方がないというわけでしたぎょ
# いずれも2008年3月12日現在でのバージョン

あとは最新ライブラリを組み込んで対策完了。
仕様の大幅変更があったために標準添付版に反映できていないと言うことでしたが……マニュアルの先頭に書いておいて欲しかったわーん

本日のリンク元
アンテナ
その他のリンク元
検索