Ktouth Brand. on Web

け〜くんこと K.Ktouth のだらだらした日常と突発的に作るプログラムや読み物とかの雑多サイト



[2011年04月22日]

続: NetBeans7.0 + Ruby

2011年04月23日 02:55更新 筆者:K.Ktouth

NetBeans Ruby and Rails IDE with JRuby (Firstpress)(AA)

先日リリースされた NetBeans7.0 に ruby 開発用パッケージがないという日記を書きましたが。
ネットで検索したら7.0以降は、ruby (および rails)開発のサポートを打ち切ったげーそうで。
動的型付け言語は「NetBeansでの利用例が少ないのでサポート態勢を集中させる」とか何とか出来られたらしく、以前サポートしていた Photon と同じ末路らしーです。

ぐはぁ……Rubyが使用可能なIDEは eclipse or Apatana というくそ重い奴しかないのかぁ……

と思っていたら、やはりこれを良しとしないコミュニティグループが ruby および rails のサポートを行うプラグイン開発を引き継いだようで、それを導入することで以前と同じように NetBeans7.0 以降でも開発が出来るようです。
ただ現状ではRoRプラグインはbetaなので、以下のようにして導入する必要有り。

これでHTML5を使用した ruby アプリが開発しやすくなったぜ♪

本日のリンク元
その他のリンク元
検索